You May be Prompted Twice for Authentication When You Access the Airweb Page (309426)



The information in this article applies to:

  • Microsoft Mobile Information 2001 Server

This article was previously published under Q309426

SYMPTOMS

When you access the personalization component of Microsoft Mobile Information Server by using http://servername/airweb, you may be prompted for your credentials twice.

CAUSE

This behavior can occur if you use the fully qualified domain name (FQDN) of the Exchange Server computer, for example, http://servername.domain.com/airweb. This behavior may also occur if you access the Airweb page on the Mobile Information Server computer, which prompts you for your credentials. After you are authenticated, you may be redirected to the Airweb page on your Exchange Server computer, which requires you to re-authenticate.

NOTE: You may only be redirected to your Exchange Server computer if you have an Exchange 2000 Server mailbox.

RESOLUTION

To resolve this behavior, use the network basic input and output system (NetBIOS) name of the Exchange Server computer, for example, http://servername/airweb.

MORE INFORMATION

The double authentication can occur because there is a redirect to a different server. After the user is authenticated, the Mobile Information Server personalization component searches Active Directory for the user's Exchange Server computer, and then redirects the user to that server. Because the Exchange Server computer information in Active Directory is not stored in FQDN format, you receive a prompt for your credentials again.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB309426