Error Message When You Try to Install Internet Explorer 6.0: A Previous Installation Has Pending Work Requiring a Reboot (309314)



The information in this article applies to:

  • Microsoft Internet Explorer version 6 for Windows Millennium Edition

This article was previously published under Q309314

SYMPTOMS

When you attempt to install Internet Explorer 6.0 on a Microsoft Windows Millennium Edition (Me)-based computer, you may receive an error message similar to the following:
A previous installation has pending work requiring a reboot. You need to restart your computer to complete that installation before running internet explorer setup. Setup will now close."

CAUSE

This behavior can occur if another program is running in the background when you attempt to install Internet Explorer.

RESOLUTION

To resolve this issue, restart your computer by performing a clean boot, and then reinstall Internet Explorer. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type msconfig, and then click OK.
  3. Click the General tab.
  4. Click to clear each check box except Load Static VxDs.
  5. Click Apply, and then click OK.
  6. When prompted, restart your computer.
  7. Restart Internet Explorer Setup.

MORE INFORMATION

Norton AntiVirus is one of the programs that can trigger this issue. For more information about Norton AntiVirus, browse to the following Symantec Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/5/2003
Keywords:kberrmsg kbprb kbsetup KB309314