Outlook Mobile Access Returns an "Error 404 - Page Not Found" Error Message If Users Have Multiple SMTP Proxy Addresses (308618)



The information in this article applies to:

  • Microsoft Mobile Information Server 2002

This article was previously published under Q308618

SYMPTOMS

When you use Outlook Mobile Access (a component of Mobile Information Server) in an environment in which multiple domains are used for users' Simple Mail Transfer Protocol (SMTP) proxy addresses, you may receive the following error message when you attempt to browse a Microsoft Exchange 2000 Server mailbox:
404 - Page Not Found

CAUSE

This issue can occur if a user has multiple SMTP proxy addresses that do not have matching aliases. Outlook Mobile Access needs to determine which alias matches the user's Exchange 2000 mailbox.

Complex Exchange 2000 environments, including many "hosting" situations, require that users have multiple SMTP proxy addresses with varying domain names for those addresses. For example, a user might have the following as SMTP proxy addresses:
  • pat@adatum.com
  • pcoleman@nwtraders.com
  • patcoleman@cpandl.com
When you create an Exchange 2000 mailbox, the Hypertext Transfer Protocol (HTTP) and Distributed Authoring Version (DAV) interface allows access to the mailbox by means of a Uniform Resource Locator (URL), which contains the user's alias. For the user in the preceding example, the mailbox URL might be http://mailserver/exchange/pcoleman. Mobile Information Server uses the SMTP proxy address of the user to determine the alias that the mailbox URL contains.

Simple environments may contain only a single SMTP proxy address for each user; therefore, Mobile Information Server can easily use the alias of that address to form the URL to retrieve mailbox data. However, if multiple addresses exist, Mobile Information Server uses the alias in the primary SMTP proxy address. If the primary SMTP proxy address has been changed from the default and the alias on that primary address does not match the alias of the mailbox URL, you cannot use Mobile Information Server to browse the mailbox.

RESOLUTION

To resolve this issue, administrators can override the behavior by specifying the fully qualified domain name (FQDN) that Mobile Information Server should use to determine which SMTP proxy address contains the correct alias to access the Exchange 2000 mailbox. You can specify the FQDN by placing the appropriate FQDN in the microsoftCom1991AirLoggingModuleCLSID attribute of the CN=Default-Site,CN=Microsoft-Mobile-Information-Server,CN=Services object in Active Directory.

To help Outlook Mobile Access determine which SMTP proxy address should be used to identify the alias that corresponds with the Exchange 2000 mailbox, the Misproxyfix.vbs script (which is located in the Support\Tools\Mis Proxy Fix folder in the Mobile Information Server 2002 installation media) automates determining and setting the microsoftCom1991AirLoggingModuleCLSID attribute, which must contain the FQDN of the SMTP proxy address that should be used to access Exchange 2000.

Use the following syntax to use the Misproxyfix.vbs script:

MISProxyFix.vbs -auto

The auto switch automatically detects the FQDN of the primary SMTP proxy address of the Exchange 2000 "Default Recipient Policy" and set the microsoftCom1991AirLoggingModuleCLSID attribute to that value:

MISProxyFix.vbs -manual fqdn.com

The manual switch takes the FQDN that follows the switch and sets the microsoftCom1991AirLoggingModuleCLSID attribute to that value. This switch is necessary if the primary SMTP proxy address of the Exchange 2000 "Default Recipient Policy" was changed from its default setting:

MISProxyFix.vbs -remove

The remove switch removes any value that is specified in the microsoftCom1991AirLoggingModuleCLSID attribute.

In addition to the script, you can use the following steps to manually determine the default recipient policy and set the appropriate attribute by using the ADSI Edit snap-in.

WARNING: If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Exchange 2000 Server, or both. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

To manually determine the default recipient policy and set the appropriate attribute by using ADSI Edit:
  1. Start Exchange System Manager.
  2. Expand the Recipients container, and then click Recipient Policies.
  3. Right-click Default Policy, and then click Properties on the shortcut menu.
  4. Click the E-mail Addresses (Policy) tab, and then note the FQDN (the information that follows the at sign [@]) on the row that contains the SMTP address type.
  5. In ADSI Edit, expand the Configuration container, and then locate CN=Default Site, CN=Mobile-Information-Server, CN=Services, CN=Configuration, DC=domain, DC=com.
  6. Right-click Properties, and then click the microsoftCom1991AirLoggingModuleCLSID attribute in the Select a property to view list.

    NOTE: In ADSI Edit, the microsoftCom1991AirLoggingModuleCLSID name is truncated, and three attributes appear as microsoftCom1991AirLoggingMo. The correct attribute is the first of the three attributes that appear with the text microsoftCom1991AirLoggingMo.
  7. In the Edit attribute box, type the FQDN that you located in step 4.
  8. Click Set, and then click OK.

Modification Type:MajorLast Reviewed:1/2/2002
Keywords:kberrmsg kbprb KB308618