Windows 98 Shutdown Hangs for Five Minutes with USB Modem Present (308349)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition

This article was previously published under Q308349

SYMPTOMS

Your computer may stop responding (hang) during the shutdown process for approximately five minutes. This problem occurs only if the following conditions exist:
  • Your Universal Serial Bus (USB) modem uses the default Windows USB modem drivers. Refer to the "Steps to Verify That Your Modem Is Affected by This Problem" section in this article to determine if your modem is affected.
  • The update that is described in the following Microsoft Knowledge Base article has been applied to your computer:

    242004 The AOL 4.0 Client Does Not Connect with USB And WDM Modems

  • A program has accessed the USB modem by using the virtual COM port.
Currently, the following USB modems are known to be affected by this problem:
  • 3Com US Robotics 56k Voice Pro USB
  • Lucent 56K USB Modem
  • Compaq 56K USB External Fax Modem
  • ELSA Microlink ISDN USB Modem

CAUSE

The USB serial device driver (Usbser.sys) leaves an outstanding input/output (I/O) request pending against the device, which prevents the program from quitting properly.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date         Time   Version      Size    File name
   ---------------------------------------------------
   03-Oct-2001  16:32  4.10.0.2224  22,336  Usbser.sys

WORKAROUND

You can temporarily work around this problem by using the following steps before you shut down your computer:
  1. Quit the communications program that you use to gain access to the modem.
  2. Press CTRL+ALT+DELETE.
  3. In the list of running programs, locate the communications program that you were using.
    • If the program is not listed, click Cancel. You should be able to shut down the computer correctly.
    • If the program is listed, click the program, click End Task, and then click Cancel.
  4. Shut the computer down as you typically would.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Steps to Verify That Your Modem Is Affected by This Problem

  1. Right-click My Computer, and then click Properties.
  2. On the Device Manager tab, double-click the Modem branch to expand it.
  3. Double-click the modem.
  4. On the Drivers tab, click Driver File Details.
  5. If the driver files that are listed include Ccport.sys, Wdmmdmld.vxd, and Usbser.sys, your modem is subject to the problem that is described in this article.
For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes

For additional information about the update that causes this problem, click the article number below to view the article in the Microsoft Knowledge Base:

242004 The AOL 4.0 Client Does Not Connect with USB And WDM Modems


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbenv kbfix kbprb kbQFE KB308349