Error Messages When You Quit the Sounds and Multimedia Tool in Control Panel (307908)



The information in this article applies to:

  • Microsoft Windows Millennium Edition

This article was previously published under Q307908
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages:

315854 Windows 98 and Windows Me Error Message Resource Center

SYMPTOMS

When you click OK or Cancel to quit the Sounds and Multimedia tool in Control Panel, your computer may stop responding (hang), or you may receive the following error message on a blue screen:
Windows

An error has occurred. To continue:

Press Enter to return to Windows, or

Press CTRL+ALT+DEL to restart your computer. If you do this, you will lose any unsaved information in all open applications.

Error: 0D : 0157 : 00005ED7

Press any key to continue
If you then press a key, the desktop may appear for a brief moment before the blue screen reappears. After this occurs, you may receive the following error messages (or similar messages) in succession on a black screen:
  • Rundll32

    RUNDLL32 caused an invalid page fault in module USER32.DLL at 0177:bff49be.
  • Explorer

    EXPLORER caused an invalid page fault in module USER.EXE at 0003:000008b2e.
Additionally, if the first Windows error message on a blue screen does not appear, you may receive error messages on the desktop that are similar to the preceding Rundll32 and Explorer error messages.

If you click Close after you receive the second or third error messages that are in this section, you may eventually receive the first error message that is listed in this section. This problem is more likely to occur if you select any item in the Sound Event list on the Sounds tab that is listed with a speaker icon.

CAUSE

This problem can occur if the Sounds and Multimedia tool improperly destroys a shared icon while it is cleaning up Graphics Device Interface (GDI) resources.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date         Time   Version    Size     File name
   -------------------------------------------------
   26-Sep-2001  16:49  4.90.3001  408,576  Mmsys.cpl
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about Windows Me hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

295413 General Information About Windows Millennium Edition Hotfixes


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kberrmsg kbfix kbInvalidPageFault kbQFE KB307908