Picture It!: Invalid page fault in module unknown (307622)



The information in this article applies to:

  • Microsoft Digital Image Pro 10
  • Microsoft Digital Image Pro 9
  • Microsoft Digital Image Suite 9
  • Microsoft Digital Image Suite 10
  • Microsoft Home Publishing 2000 2000
  • Microsoft Picture It! Digital Image Pro version 7
  • Microsoft Picture It! Express 9
  • Microsoft Picture It! Express 10
  • Microsoft Picture It! Photo version 7
  • Microsoft Picture It! Photo Premium version 7
  • Microsoft Picture It! Photo 2002
  • Microsoft Picture It! Photo Premium 2002, version 1.0
  • Microsoft Picture It! Photo Premium 9
  • Microsoft Picture It! Photo Premium 10
  • Microsoft Picture It! Publishing 2001 Gold
  • Microsoft Picture It! Publishing 2001 Platinum
  • Microsoft Picture It! Publishing 2001 Silver
  • Microsoft Picture It! Publishing 2002, Gold, version 1.0
  • Microsoft Picture It! Publishing Platinum 2002 1.0
  • Microsoft Digital Image Standard Edition 2006
  • Microsoft Digital Image Starter Edition 2006
  • Microsoft Digital Image Suite 2006

This article was previously published under Q307622

SYMPTOMS

When you start one of the programs listed in the "Applies To" section, you may receive the following error message:
PIP has caused an Invalid Page Fault in module unknown
Microsoft Digital Image version has encountered an error and needs to close.
When you print from in any of the programs listed in the "Applies To" section, you may receive the following error message:
Program caused an invalid page fault in module <unknown>
When working on a project in any of the programs listed in the "Applies To" section, you may receive you may receive the following error message:
Program has caused an Invalid Page Fault in module unknown

CAUSE

This issue may occur if the video driver for your video adapter is outdated or is corrupted.

RESOLUTION

To troubleshoot this issue, use one of the following methods.

Method 1: Install the latest video driver

You may be able to resolve this issue by downloading and installing the latest video driver available for your video adapter. Contact your video card manufacturer or computer manufacturer to inquire about how to obtain and install the latest driver for your video adapter.

For information about how to contact your video card manufacturer or computer manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
Start the affected program to see if the issue is resolved. If you receive the error message again, proceed to method 2.

Method 2: Reduce the graphics hardware acceleration

To reduce graphics hardware acceleration, follow the steps appropriate for your operating system.

Microsoft Windows 98, Microsoft Windows 98 Second Edition, and Microsoft Windows Millennium Edition (Me)

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Performance tab, and then click Graphics.
  4. Move the Hardware Acceleration slider to None.
  5. Click OK twice.
  6. When you are prompted to restart the computer, click Yes.
  7. Test to see if the issue is resolved. If the issue is resolved, you may be able to adjust the hardware acceleration to a level that provides some acceleration, but does not cause the error message.

Microsoft Windows 2000

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Display.
  3. Click the Settings tab, click Advanced, and then click the Troubleshooting tab.
  4. Move the Hardware Acceleration slider to None.
  5. Click OK twice.
  6. When you are prompted to restart the computer, click Yes.
  7. Test to see if the issue is resolved. If the issue is resolved, you may be able to adjust the hardware acceleration to a level that provides some acceleration, but does not cause the error message.

MORE INFORMATION

For more information about how to troubleshoot graphics issues in Picture It! Publishing, click the following article number to view the article in the Microsoft Knowledge Base:

272193 Picture It!: How to troubleshoot graphics issues


Modification Type:MinorLast Reviewed:1/9/2006
Keywords:kberrmsg kbprb KB307622