Error message when you try to open or save an e-mail attachment in Outlook: "Cannot create file" (305982)



The information in this article applies to:

  • Microsoft Outlook 2000
  • Microsoft Office Outlook 2003

This article was previously published under Q305982
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you try to open or save an e-mail attachment, you may receive the following error message:
Cannot create file: file name. Right-click the folder you want to create the file in and click Properties on the shortcut menu to check your permissions for the folder.

CAUSE

This issue may occur when the Temporary Internet Files folder is stored on a server on which you do not have sufficient permissions.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. To resolve this issue, force Outlook to use a specific folder for temporary files. Modify the relevant Windows Registry key as follows:

Outlook 2000

If you are using Outlook 2000, follow these steps:
  1. Start Registry Editor.
  2. Locate and then click the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Security\OutlookSecureTempFolder


    Note You may have to manually create this registry key if it does not already exist on the system.

    If Outlook is installed on a terminal server, use the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\MICROSOFT\Office\9.0\Outlook\SECURITY\OutlookSecureTempFolder

  3. On the Edit menu, click Modify, and then add the following registry value:

    Value data: Path and name of the folder that you want to use

  4. Exit Registry Editor.

Outlook 2003

If you are using Outlook 2003, follow these steps:
  1. Click My Computer, and then double-click drive C.
  2. On the File menu, click New, and then click Folder.
  3. Name the folder temp0.
  4. Click Start, click Run, type regedit, and then click OK.
  5. Locate and then click the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Security\

  6. In the right pane, double-click OutlookSecureTempFolder.
  7. In Value Data field, type C:\temp0\ and then click OK.
  8. Exit Registry Editor.
  9. Restart the computer.

MORE INFORMATION

Microsoft Outlook 2000 Service Release 1 has a security enhancement that saves the attachment as a temporary file. The file is saved in the Temporary Internet Files folder in a folder that has a random name. When roaming profiles are set up, the Temporary Internet Files folder is stored in the user's profile on a server. The user gains access to the folder over the network.

Modification Type:MajorLast Reviewed:3/6/2006
Keywords:kbattachments kbemail kbsavefile kbRegistry kberrmsg kbprb KB305982