Toolbar, toolbar button, or menu bar is missing in Visio (305400)



The information in this article applies to:

  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
  • Microsoft Visio 2002 Standard
  • Microsoft Visio 2002 Professional
  • Microsoft Visio 2000 Standard Edition
  • Microsoft Visio 2000 Technical Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Enterprise Edition

This article was previously published under Q305400
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

In Microsoft Visio, you may experience one or more of the following symptoms:
  • A toolbar that you know is enabled is not visible.
  • The menu bar is missing.
  • Buttons are missing from a toolbar.

CAUSE

These symptoms can occur if you accidentally drag a toolbar or a menu bar outside the area of the visible screen.

Similar behavior can also occur if either of the following conditions is true:
  • The display resolution is too low to display all the buttons on a toolbar.
  • Two toolbars are docked next to each other on the same row. In this case, Visio hides some buttons.

RESOLUTION

To restore the toolbars or the menu bar, use any one of the following methods:
  • Set the display resolution to 800 x 600 or higher.
  • Have each toolbar appear on its own row.
  • Restore the default settings.

    WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

    1. Quit all instances of Visio.
    2. Click Start, click Run, type regedit, and then click OK.
    3. Click the following registry subkey in the left pane of Registry Editor as appropriate:
      • Visio 2003

        HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Visio\Toolbars

      • Visio 2002

        HKEY_CURRENT_USER\Software\Microsoft\Visio\Toolbars

      • Visio 2000

        HKEY_Current_User\Software\Visio\Visio 2000\Toolbars

    4. On the Edit menu, click Delete. The Toolbars subkey will be deleted.
    5. If you are prompted to confirm the deletion, click Yes.
    6. On the Registry menu, click Exit.

      Registry Editor automatically saves your changes.
When you restart Visio, Visio re-creates the deleted subkey and restores the toolbars and the menu bars to their default locations.

MORE INFORMATION

For more information about how to troubleshoot a similar issue, click the following article numbers to view the articles in the Microsoft Knowledge Base:

873298 Toolbars that you customize are reset to use the default settings when you restart Visio 2003 or Visio 2002

291213 Menus, toolbars, and stencils disappear in full-screen view in Visio

For more information about customizing the Visio interface, click the following article numbers to view the articles in the Microsoft Knowledge Base:

305069 How to create custom toolbars and tool buttons in Visio 2002 or in Visio 2003

305060 How to customize, create, and restore Visio menus in Visio 2002 or in Visio 2003


Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbtshoot kbprb KB305400