"XML Page Cannot Be Displayed" Error Message When You Open An XML File Attachment in E-Mail (303487)
The information in this article applies to:
- Microsoft Outlook Express 5.5 for Windows NT 4.0 SP 2
- Microsoft Outlook Express 5.01 for Windows NT 4.0 SP 1
- Microsoft Outlook Express 5.0 for Windows NT 4.0
- Microsoft Outlook Express 5.5 for Windows Millennium Edition SP 1
- Microsoft Outlook Express 5.5 for Windows Millennium Edition SP 2
- Microsoft Outlook Express 5.5 for Windows 98 Second Edition SP 1
- Microsoft Outlook Express 5.5 for Windows 98 Second Edition SP 2
- Microsoft Outlook Express 5.01 for Windows 98 Second Edition SP 1
- Microsoft Outlook Express 5.0 for Windows 98 Second Edition
- Microsoft Outlook Express 5.5 for Windows 98 SP 1
- Microsoft Outlook Express 5.5 for Windows 98 SP 2
- Microsoft Outlook Express 5.01 for Windows 98 SP 1
- Microsoft Outlook Express 5.0 for Windows 98
- Microsoft Outlook Express 5.5 for Windows 95 SP 1
- Microsoft Outlook Express 5.5 for Windows 95 SP 2
- Microsoft Outlook Express 5.01 for Windows 95 SP 1
- Microsoft Outlook Express 5.0 for Windows 95
- Microsoft Outlook Express 5.5 for Windows 2000 SP 1
- Microsoft Outlook Express 5.5 for Windows 2000 SP 2
- Microsoft Outlook Express 5.01 for Windows 2000
- Microsoft Internet Explorer 5.5 for Windows NT 4.0 SP 1
- Microsoft Internet Explorer 5.5 for Windows NT 4.0 SP 2
- Microsoft Internet Explorer 5.01 for Windows NT 4.0 SP 1
- Microsoft Internet Explorer 5.01 for Windows NT 4.0 SP 2
- Microsoft Internet Explorer 5.0 for Windows NT 4.0
- Microsoft Internet Explorer 5.5 for Windows Millennium Edition SP 1
- Microsoft Internet Explorer 5.5 for Windows Millennium Edition SP 2
- Microsoft Internet Explorer 5.5 for Windows 98 Second Edition SP 1
- Microsoft Internet Explorer 5.5 for Windows 98 Second Edition SP 2
- Microsoft Internet Explorer 5.01 for Windows 98 Second Edition SP 1
- Microsoft Internet Explorer 5.01 for Windows 98 Second Edition SP 2
- Microsoft Internet Explorer 5.0 for Windows 98 Second Edition
- Microsoft Internet Explorer 5.5 for Windows 98 SP 1
- Microsoft Internet Explorer 5.5 for Windows 98 SP 2
- Microsoft Internet Explorer 5.01 for Windows 98 SP 1
- Microsoft Internet Explorer 5.01 for Windows 98 SP 2
- Microsoft Internet Explorer 5.0 for Windows 98
- Microsoft Internet Explorer 5.5 for Windows 95 SP 1
- Microsoft Internet Explorer 5.01 for Windows 95 SP 1
- Microsoft Internet Explorer 5.01 for Windows 95 SP 2
- Microsoft Internet Explorer 5.0 for Windows 95
- Microsoft Internet Explorer 5.5 for Windows 2000 SP 1
- Microsoft Internet Explorer 5.5 for Windows 2000 SP 2
- Microsoft Internet Explorer 5.01 for Windows 2000 SP 1
- Microsoft Internet Explorer 5.01 for Windows 2000 SP 2
- Microsoft Internet Explorer version 6 for Windows XP 64-Bit Edition
- Microsoft Internet Explorer version 6 for Windows XP
- Microsoft Internet Explorer version 6 for Windows 2000
- Microsoft Internet Explorer version 6 for Windows NT 4.0
- Microsoft Internet Explorer version 6 for Windows Millennium Edition
- Microsoft Internet Explorer version 6 for Windows 98 Second Edition
- Microsoft Internet Explorer version 6 for Windows 98
- Microsoft Outlook 2002
- Microsoft Outlook 2000
This article was previously published under Q303487 SYMPTOMS
When you attempt to open an Extensible Markup Language (XML) document attached to an e-mail message, you may receive the following error message in a Microsoft Internet Explorer browser window:
The XML page cannot be displayed.
Cannot view XML input using style sheet. Please correct the error and then click the Refresh button, or try again later.
Access is denied.
CAUSE
This behavior occurs if both of the following conditions are true:
- The .xml file is attached to a Microsoft Outlook or Microsoft Outlook Express e-mail message.
-and- - You attempt to open the .xml file attachment either by double-clicking the attachment or by right-clicking the attachment and then clicking Open.
When you open an attachment in an HTML or XML-formatted mail message, the attachment is placed in the Temporary Internet Files folder on your computer's hard disk, and Internet Explorer opens the file from this location. Internet Explorer is unable to load .xml files from the Temporary Internet Files folder, and as a result, when you attempt to open an .xml file attachment from an Outlook or Outlook Express e-mail message, you receive the message described in the "Symptoms" section of this article.
WORKAROUND
To work around this issue, save the .xml file attachment to another location on your hard disk, and then open the file from this location. To do this, follow these steps:
- Start Outlook or Outlook Express, and then open the message that contains the .xml file attachment that you want to open.
- Right-click the attachment, and then click Save As.
- In the Save Attachment dialog box, specify a name and a location in which to save the file, and then click Save.
- Close the message window.
- Start Windows Explorer, and then locate the .xml file that you saved in step 3.
- Double-click the file to open it.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. MORE INFORMATION
The Temporary Internet Files folder (Internet Explorer cache) is the location on your hard disk in which Web pages and other files, such as graphics, are stored as you view them. This feature speeds up the display of pages that you frequently visit or have already viewed, because Internet Explorer can access and open them from your hard disk instead of from the Web.
Modification Type: | Minor | Last Reviewed: | 9/14/2006 |
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Keywords: | kberrmsg kbpending kbprb KB303487 |
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