PIP2001: Error Message When You Start or Run Picture It!: PIP Has Caused an Error in Kernel32.dll (303177)
The information in this article applies to:
- Microsoft Picture It! Photo 2001
- Microsoft Picture It! Photo Premium 2001
- Microsoft Picture It! Publishing 2001 Gold
- Microsoft Picture It! Publishing 2001 Platinum
- Microsoft Picture It! Publishing 2001 Silver
This article was previously published under Q303177 WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion. SYMPTOMS
When you attempt to start, or when you actually run, one of the Microsoft Picture It! programs listed in the "Applies to" section of this article, you may receive an error message similar to the following:
PIP has caused an error in Kernel32.dll
When you click Close, you may then receive the following error message:
PIP has caused an error in [unknown]
When you click Close in the message dialog box, the program appears to quit. However, you are then unable to restart the program. If you press CTRL+ALT+DELETE, the Picture It! program may be listed in the Close Program dialog box (if you are running Microsoft Windows 98 or Microsoft Windows Millennium Edition [Me]). Or, it may be listed as "Running" on the Applications tab of the Windows Task Manager (if you are running Microsoft Windows 2000 or Microsoft Windows NT).
CAUSE
This behavior can occur if all of the following conditions are true:
- You are using one of the following Hewlett-Packard (HP) printers:
- HP DeskJet 970CSE
- HP DeskJet 930C
-and-
- The printer is connected through your parallel (LPT) port.
-and- - There is a problem with the printer driver: for example, the driver is damaged or outdated.
RESOLUTION
To resolve this issue, remove your existing printer driver, and then download and install the latest driver available for your HP printer. To do this, follow these steps:
- Click Start, point to Settings, point to Control Panel, and then click Add/Remove Programs.
- If you are running Windows 2000:
- Under Currently installed programs, select your HP printer driver (if it is displayed in the list), and then click Remove.
- Click Yes to the Are you sure you want to completely remove the program and all of its components? message.
If you are running Microsoft Windows 95, Windows 98, Windows Me, or Windows NT:
- On the Install/Uninstall tab, select your HP printer driver (if it is displayed in the list), and then click Add/Remove.
- Click Yes to the Are you sure you want to completely remove the program and all of its components? message.
- Click Start, point to Settings, and then click Printers.
- Right-click the printer that you want to remove, and then click Delete.
- Click Yes to the Are you sure you want to delete the printer? message.
- Restart your computer.
- Download the latest driver for your printer. To do this, browse to the following Hewlett-Packard Web site:
- Click Start, point to Settings, and then click Printers.
- Double-click Add Printer, and then click Next in the Welcome to the Add Printer Wizard dialog box.
- Click Local printer, and then click Next.
- In the Select the Printer Port dialog box, click Use the following port, click LPT1, and then click Next.
- In the Add Printer Wizard dialog box, click Have Disk.
- Type the path along which the driver that you downloaded in step 7 is located, or click Browse to locate the folder, and then click OK.
- Follow the instructions on the screen to finish installing the printer driver.
Modification Type: | Minor | Last Reviewed: | 1/9/2006 |
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Keywords: | kberrmsg kbprb KB303177 |
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