Error message: Error 1402. Could not open key... (303089)



The information in this article applies to:

  • Microsoft Access 2000
  • Microsoft Access 2002
  • Microsoft Office Access 2003
  • Microsoft Encarta Encyclopedia Deluxe 2001 for Windows
  • Microsoft Encarta Encyclopedia Standard 2002 1.0
  • Microsoft Excel 2000
  • Microsoft Excel 2002
  • Microsoft Office Excel 2003
  • Microsoft FrontPage 2000
  • Microsoft FrontPage 2002
  • Microsoft Office FrontPage 2003
  • Microsoft Office Live Meeting
  • Microsoft Money 2001 Deluxe and Business
  • Microsoft Money 2002
  • Microsoft Money 2003 Standard
  • Microsoft Office 2000
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professional
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Standard
  • Microsoft Office 2003, All Editions
  • Microsoft Office 2003 Web Components
  • Microsoft Office XP
  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business
  • Microsoft Office XP Standard
  • Microsoft Office OneNote 2003
  • Microsoft Outlook 2000
  • Microsoft Outlook 2002
  • Microsoft Office Outlook 2003
  • Microsoft Picture It! Digital Image Pro version 7
  • Microsoft Picture It! Publishing 2001 Gold
  • Microsoft Picture It! Publishing 2002, Gold, version 1.0
  • Microsoft Picture It! Publishing Platinum 2002 1.0
  • Microsoft Picture It! Publishing 2001 Silver
  • Microsoft Picture It! Publishing 2001 Platinum
  • Microsoft PowerPoint 2000
  • Microsoft PowerPoint 2002
  • Microsoft Office PowerPoint 2003
  • Microsoft Project 2000
  • Microsoft Project 2002
  • Microsoft Office Project Professional 2003
  • Microsoft Office Project Server 2003
  • Microsoft Office Project Standard 2003
  • Microsoft Publisher 2000
  • Microsoft Publisher 2002
  • Microsoft Office Publisher 2003
  • Microsoft Streets & Trips 2002 1.0
  • Microsoft Visio 2000 Enterprise Edition
  • Microsoft Visio 2000 Professional Edition
  • Microsoft Visio 2000 Standard Edition
  • Microsoft Visio 2000 Technical Edition
  • Microsoft Visio 2002 Standard
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
  • Microsoft Word 2000
  • Microsoft Word 2002
  • Microsoft Office Word 2003
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2004
  • Microsoft Works Suite 2003
  • Microsoft Works Suite 2002
  • Microsoft Works Suite 2001
  • Microsoft Works 8.0
  • Microsoft Works Suite 2006

This article was previously published under Q303089
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

Note This article does not apply to Microsoft Windows XP or Microsoft Windows 2000.

When you try to install any of the products listed in the "Applies To" section, you may receive an error message that is similar to the following:
Error 1402. Could not open key key name.

Verify that you have sufficient access to that key, or contact your support personnel.

Installation cannot proceed.
In this error message, key name is the name of a key that the Setup program is trying to write to the Microsoft Windows registry.

CAUSE

This behavior may occur if there is incorrect, invalid, or corrupted information in the Windows registry. This behavior may occur if specific files or folders were previously removed or renamed on your hard disk. As a result, registry entries associated with the deleted files remain in the Windows registry.

RESOLUTION

To resolve this issue, run the Windows Registry Checker Tool (Scanreg.exe) to scan your registry for invalid entries. The Registry Checker scans, detects, and repairs damages in the system registry, and, if necessary, restores a backup of the registry. To run the Registry Checker, follow the steps appropriate for your operating system.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Method 1: Microsoft Windows Millennium Edition

  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click System Information.
  2. On the Tools menu, click Registry Checker. You may receive the following error message:
    Windows encountered an error accessing the system registry. Windows will restart the computer and repair the system registry for you.
    If you receive this error message, continue to step 3.

    If you do not receive the error message, follow these steps to repair damage to the registry:
    1. Quit all the programs that are running.
    2. Click Start, click Run, type the following text in the Open box, and then click OK:

      scanreg /fix

    3. Click Yes to restart the computer.
  3. Click OK to restart your computer.
  4. Follow the remaining steps to restore a good copy of the registry.
  5. Insert Disc 1 of your Microsoft Works installation CD into your CD drive and run the Works Setup program.

Method 2: Microsoft Windows 98 or Microsoft Windows 98 Second Edition

  1. Restart your computer. Press and hold down the CTRL key until the Windows 98 Startup menu appears, and then select Command prompt only.
  2. At the command prompt, type scanreg /fix, and then press ENTER.
  3. After the Registry Checker tool completes repairing the registry, press ENTER.
  4. At the command prompt, type scanreg /opt, and then press ENTER.

    Note The /opt command-line switch causes the Registry Checker tool to optimize the registry by removing unused space.
  5. Restart the computer.
  6. Insert Disc 1 of your Works installation CD into your CD drive and run the Works Setup program.

MORE INFORMATION

The Registry Checker Tool scans the system registry for invalid entries and empty data blocks. If the Registry Checker detects invalid entries, it automatically restores the previous day's backup. This is equivalent to running the scanreg /autorun command from a command prompt. If no backups are available, the Registry Checker tries to repair the registry. This is equivalent to running the scanreg /fix command from a command prompt. If the registry contains more than 500 kilobytes (KB) of empty data blocks, the Registry Checker automatically optimizes the unused space.

For more information about how to troubleshoot the "Error 1402" error message, click the following article number to view the article in the Microsoft Knowledge Base:

236427 You receive an "Error 1402. Could not open key" error message when you run Office 2000 Setup

For more information about the Registry Checker Tool, click the following article numbers to view the articles in the Microsoft Knowledge Base:

183887 Description of the Windows Registry Checker Tool (Scanreg.exe)

183603 How to customize Registry Checker Tool settings

184023 Command-line switches for the Registry Checker Tool


Modification Type:MinorLast Reviewed:1/9/2006
Keywords:kbprb KB303089