Computer with OSB4 Chip Set May Hang in ACPI Mode (299877)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

This article was previously published under Q299877
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

On a computer with a Reliance Computer Corp./ServerWorks OSB4 chip set that is running Windows 2000 in ACPI mode, the following symptoms might occur when you are using the ACPI Power Management Timer (PMTimer) as a high-resolution counter:
  • You may experience problems or poor performance when playing back audio or video streams.
  • Your computer may display an error message on a blue screen and stop responding (hang).

CAUSE

This problem can occur in this chip set when the chip set causes the PMTimer to make time appear to run backwards. Other chip sets also exhibit this behavior and are documented in the following Microsoft Knowledge Base article:

266344 Your Computer May Hang When Running in ACPI Mode

The referenced article indicates that a resolution to this problem was included in Service Pack 1 (SP1), but the OSB4 chip set was not included with this fix.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Use the following steps to resolve this issue:
  1. Make sure that you are running Windows 2000 SP1 or later.
  2. Start Registry Editor (Regedt32.exe).
  3. Locate and click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\HAL

  4. On the Edit menu, click Add Value, and then add the following value:

    Value name: 11660200
    Data type: REG_DWORD
    Data: 00000001

  5. Quit Registry Editor, and then restart the computer.

MORE INFORMATION

To determine whether your computer uses the chip set that is listed in this article:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the System icon.
  3. On the Hardware tab, click Device Manager.
  4. Double-click the System Devices branch to expand the branch.
  5. Locate the PCI to ISA Bridge device. This device should contain a description that identifies the chip set.
Note that the behavior that is described in this article is not a problem with the Microsoft products that are listed at the beginning of this article. This is a hardware problem; Microsoft is providing this resolution to prevent this issue from occurring on Windows 2000-based computers that have chip sets from the manufacturers listed earlier in this article.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:12/3/2003
Keywords:kbprb KB299877