Computer Can Hang Indefinitely with Heavy I/O Loads (299842)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP1

This article was previously published under Q299842

SYMPTOMS

If you are using the Iometer tool to generate a load on ten devices with 2-MB random writes and a transfer rate of about 45 MB, running inquiries to a specific device can take roughly 10 to 15 seconds. If you change the I/O parameters to 1-MB transfers, the inquiry is returned normally. If you change the I/O parameters to allow 5 outstanding I/O operations per target, the inquiry may stop responding (hang).

CAUSE

When the disks are receiving I/O requests and the INQUIRY IOCTL is received, Windows also scans the bus for the inquiry data. Scsiport issues individual untagged INQUIRY commands to multiple LUNs on each target. Each of these untagged INQUIRY commands has to wait for a slot in which to run, so the wait time is arbitrary.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English version of this fix should have the following file attributes or later:
   Date      Time    Version        Size     File name
   -------------------------------------------------------
   6/5/2001 05:20p  5.0.2195.3687  72,720   Scsiport.sys 
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbOSWin2000fix kbWin2000PreSP3Fix kbWin2000sp3fix KB299842