PRB: Computer Management MMC Causes an Error to Appear After Uninstalling Triggers (299646)



The information in this article applies to:

  • Microsoft Message Queuing 2.0

This article was previously published under Q299646
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After uninstalling Microsoft Message Queuing (MSMQ) Triggers, if you open the Computer Management Microsoft Management Console (MMC) and expand Services and Applications, a dialog box appears stating the following:
Snap-in failed to initialize:
Name: MSMQTriggers
CLSID: {<Registered CLSID>}

CAUSE

A registry key is left over after you have uninstalled triggers.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Use the following procedure to delete the registry key and resolve this problem:
  1. Start Registry Editor (Regedt32.exe).
  2. Locate the following key in the registry and click it:

    HKEY_LOCAL_MACHINE\Software\Microsoft\MMC\NodeTypes\{<CLSID>}\Extensions\Namespace\{<Registered CLSID>}

    NOTE: This registry key is one path; it may appear wrapped for readability.

  3. From the Edit menu, choose Delete, and then click Yes to confirm.
  4. Quit Registry Editor.
  5. Start Computer Management.
  6. Expand the Services and Applications tree and you will see that the error no longer occurs.

Modification Type:MajorLast Reviewed:4/18/2005
Keywords:kbprb KB299646