Logoff Process May Not Be Completed Because Time-Out Is Too Slow (299386)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

This article was previously published under Q299386
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you configure your Terminal Services server to end (reset) any idle or disconnected sessions after a certain amount of time, you may experience one or more of the following symptoms:
  • When you attempt to re-map a distributed file system (DFS) drive, you may be unable to do so, and you may receive the following error message:
    System error 85 has occurred. The local device name is already in use.
  • Roaming profiles are not unloaded or written back.

CAUSE

When a session is reset by such an external event, the session is given three minutes to end all processes and to perform a "graceful" logoff process. If the time-out period of three minutes is exceeded, all processes (including Winlogon) are terminated. This may cause a problem in environments in which a typical logoff process may already take that long. Roaming profiles and logoff scripts may contribute to this time.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The English version of this fix should have the following file attributes or later:
   Date        Time    Version           Size     File name
   -------------------------------------------------------------------
   5/21/2001   02:04p   5.0.2195.3408   122,640   Icaapi.dll
   3/27/2001   11:54a   5.0.2195.3408    93,456   Licmgr.exe
   3/27/2001   11:53a   5.0.2195.3408   330,000   Lserver.exe
   5/21/2001   02:04p   5.0.2195.3408    26,384   Mstlsapi.dll
   5/21/2001   02:01p   5.0.2195.3634   141,584   Termsrv.exe
   5/21/2001   02:04p   5.0.2195.3408    23,312   Tls236.dll 
				

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

After you install the hotfix, this time-out value is configurable. To extend the time-out, install the hotfix and then create the following registry value:
  1. Start Registry Editor (Regedt32.exe).
  2. Locate and click the following key in the registry:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server

  3. On the Edit menu, click Add Value, and then add the following registry value:

    Value name: LogoffTimeout
    Data type: REG_DWORD
    Radix: Decimal
    Value data: Timeout in 2-second units (for example, a value of 120 is equivalent to four minutes)

    Do not set this value lower than 3 minutes. Also, do not use a high value (above 15 minutes) to deal with other time-out problems.
  4. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbTermServ kbWin2000PreSP3Fix kbWin2000sp3fix KB299386