Import Process May Stop Responding on Multiprocessor Computer (298824)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q298824

SYMPTOMS

If you try to import log file data into Commerce 2000 Data Warehouse on a multiprocessor computer, the import process may stop responding (hang).

CAUSE

This problem occurs because multiple threads are sharing the exclusion data that is located in ExcludeCriteria in the SiteURL table.

RESOLUTION

To resolve this problem, obtain the latest service pack for Commerce Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

297216 INFO: How to Obtain the Latest Commerce Server 2000 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000. This problem was first corrected in Commerce Server 2000 Service Pack 1.

MORE INFORMATION

This problem has only been reproduced on multiprocessor computers that have eight or more processors.

Modification Type:MajorLast Reviewed:10/21/2002
Keywords:kbbug kbCommServ2000SP1fix KB298824