Content Analyzer Scheduled Job Fails to Operate Due to Registry Access (298813)
The information in this article applies to:
- Microsoft Site Server 3.0 Commerce Edition
This article was previously published under Q298813 SYMPTOMS
Content Analyzer generates a report that has only one page when you run it through a schduled task. In other words, when you try to crawl (by using a schduled task) a Web site that has Basic Authentication enabled and no user is logged on to the server, the report shows that only one page was crawled.
Security Event log data shows access is denied to the system account that is attempting to access the registry for the needed information.
CAUSE
Hkey_currentuser is being used, which prevents access to the service account because the key was populated by the user who logged on (for example, the administrator), and is only accessible by that user.
WORKAROUND
To work around this problem, do one of the following:
- Make sure that someone is logged on to the server running Content Analyzer at all times.
-or-
- Disable Basic Authentication on the Web site that you are crawling with Content Analyzer. Note that the security policy on the Web site may not allow for this option.
-or-
- Use Windows 2000 and configure the Task Scheduler to start under the user account context (for example, the administrator).
RESOLUTIONA supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Site Server service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
Date Time Version Size File name Platform
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05/14/2001 03:19 PM 7.0.1318.0 410,464 Cacmd.exe X86
05/14/2001 03:25 PM 7.0.1318.0 456,256 Casdk.dll X86
05/14/2001 03:20 PM 7.0.1318.0 2,168,400 Sanalyst.exe X86
STATUSMicrosoft has confirmed that this is a problem in Site Server 3.0, Commerce Edition.
Modification Type: | Minor | Last Reviewed: | 10/6/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbQFE KB298813 |
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