Visio2000: Microsoft Office XP Upgrade Causes Visio to Stop Responding When Started (297885)
The information in this article applies to:
- Microsoft Visio 2000 Standard Edition
- Microsoft Visio 2000 Professional Edition
- Microsoft Visio 2000 Technical Edition
- Microsoft Visio 2000 Enterprise Edition
- Microsoft Office XP Professional
- Microsoft Office XP Small Business
- Microsoft Office XP Standard
- Microsoft Office XP Students and Teachers
- Microsoft Office XP Developer
- Microsoft Access 2002
- Microsoft Excel 2002
- Microsoft FrontPage 2002
- Microsoft Outlook 2002
- Microsoft PowerPoint 2002
- Microsoft Word 2002
This article was previously published under Q297885 SYMPTOMS
If you upgrade Microsoft Office 2000 to Microsoft Office XP, and then start Microsoft Visio 2000, you receive the following message
Please wait while Visio updates its directory cache.
and Visio stops responding when the progress bar is at 80% (percent).
-or-
The Windows Installer displays the following message
Preparing to install ...
and Visio never completely starts, because the message box never closes.
CAUSE
This problem occurs when any of the following conditions is true.
Case 1- You install Office 2000.
- You install the non SR-1 version of Visio 2000.
- You install Office XP and choose to have Office 2000 removed during the Office XP installation.
NOTE: When you click Upgrade Now during the Office XP installation, Office 2000 is automatically removed.
Case 2- You install Office 2000.
- You install Visio 2000 Service Release 1 (SR-1) by using the unattended installation package, Vis2000.msi.
NOTE: Vis2000.msi is only available on Select CDs. - You install Office XP and choose to have Office 2000 removed during the Office XP installation.
Case 3- You install Office 2000.
- You install the non SR-1 version of Visio 2000.
- You install Office XP and choose to keep Office 2000 installed during the Office XP installation.
- You uninstall Office 2000 at any time after the Office XP installation is finished.
RESOLUTION
To resolve this problem, use the appropriate methods for your situation.
Method 1: Reinstall Microsoft Visual Basic for Applications
To resolve this issue, reinstall the Windows Installer package for Visual Basic for Applications (VBA6.msi). To do this, follow these steps:
- Quit all programs that are running on your computer, including any antivirus programs.
- Open the following folder on your Microsoft Visio CD:
- Right-click Vba6.msi, and then click Install on the shortcut menu.
- Click OK when the installation is finished.
Method 2: Preventative Measure for Corporate Deployment
If you are deploying Office XP across a large number of computers, you can "chain" the installation of the Vba6.msi Windows Installer package onto the Office XP installation. This prevents the behavior from occurring in the first place. For additional information about how to chain the Vba6.msi package, click the article number below
to view the article in the Microsoft Knowledge Base:
298089 OFFXP: Visio Does Not Start After You Install Office XP
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 2/21/2006 |
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Keywords: | kbbug kbpending KB297885 |
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