Incorrect Reason Message Is Returned in Non-Delivery Reports (297013)



The information in this article applies to:

  • Microsoft Commercial Internet System 2.0
  • Microsoft Commercial Internet System 2.5

This article was previously published under Q297013

SYMPTOMS

After a user sends a message, the user may receive the following message in a non-delivery report (NDR):

Connection to [domain-name] failed. No Ip address found from [domain-name]-[IP address] [email address]

The operation completed successfully.

CAUSE

The process attempts to obtain the error code for the failure. This problem can occur if the error code is not returned in a timely manner; the error text is set to "The operation completed successfully."

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date          Time    Version       Size      File name
   ---------------------------------------------------------
   30-Apr-2001   21:07   5.5.1877.75   534,288   Smtpsvc.dll
				

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commercial Internet System versions 2.0, 2.5.

Modification Type:MinorLast Reviewed:9/2/2005
Keywords:kbbug kbfix kbQFE KB297013