Starting Internet Services Manager May Cause Error Message After Installing an ISA Server Hotfix (296638)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000

This article was previously published under Q296638
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start Internet Services Manager, you may receive the following error message:
The service configuration dynamic link library (the path in the reg value) failed to load correctly: The specified module could not be found.

CAUSE

After you install a hotfix for Internet Security and Acceleration (ISA) Server, three redundant values are added under the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InetMgr\Parameters\AddOnServices

The values that are added are:

Web Proxy
WinSock Proxy
Socks Proxy

Adding those values can cause the error message to occur. These error message may also be displayed when you start the Services and Applications object in the Computer Management snap-in.

This is a problem with the hotfix installer, not with the hotfix itself.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

If you are experiencing these problems, use Registry Editor to remove the redundant entries in the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InetMgr\Parameters\AddOnServices

Remove these values:

Web Proxy
WinSock Proxy
Socks Proxy

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:10/22/2002
Keywords:kberrmsg kbprb KB296638