No Information Is Returned When You Use the WMIC Tool (290218)



The information in this article applies to:

  • Microsoft Windows XP Professional

This article was previously published under Q290218

SYMPTOMS

When you run the Windows Management Instrumentation Command-line (WMIC) at the command prompt, no information is returned by using the /? switch or other switches.

Note: By default, you must be an administrator to run this utility.

CAUSE

This behavior occurs because the Root\Cli namespace is either damaged or missing.

RESOLUTION

To resolve this behavior, download CIM Studio from the following Microsoft Web site: Use CIM Studio to verify that the following Windows Management Instrumentation (WMI) namespace exists:

\\.\root\cli

  1. Click Start, click Programs, click WMI, click SDK, and then click CIM Studio.
  2. In the Connect to Namespace box, verify that it reads "root\cli", and then click OK.
  3. Click OK on the logon screen, use the current credentials as well as the default authentication levels.
  4. Click MSFT_CliAlias, and then click Instances.
If you cannot connect to the \\root\cli namespace, go to %SystemRoot%\System32\Wbem, and then type mofcomp cli.mof.

If you cannot instantiate the aliases, go to %SystemRoot%\System32\Wbem, and then type the following two commands:

mofcomp cliegaliases.mof

mofcomp cliegaliases.mfl


Modification Type:MinorLast Reviewed:1/15/2006
Keywords:kbenv kbprb KB290218