ACC2002: Error Refreshing Text File with Linked Table Manager (289611)



The information in this article applies to:

  • Microsoft Access 2002

This article was previously published under Q289611
Novice: Requires knowledge of the user interface on single-user computers.

For a Microsoft Access 2000 version of this article, see 199251.

SYMPTOMS

When you create a link to a text file from Microsoft Access and then move the text file to another folder, you may receive the following error message when you try to use the Linked Table Manager to refresh the link:
The Microsoft Jet database engine could not find the object <file name>. Make sure the object exists and that you spell its name and the path name correctly.

CAUSE

A specification is created when you create a link to a text file. If you quit Microsoft Access, move the text file to another folder, and then restart Microsoft Access, the specification no longer works because the path to the text file has changed.

RESOLUTION

Remove the link to the text file, and then re-create the link to the text file in its new location.

MORE INFORMATION

Steps to Reproduce the Behavior

  1. Open the sample database Northwind.mdb, and then click the Customers table.
  2. On the File menu, click Export.
  3. In the Export Table 'Customers' To dialog box, click Text Files in the Save as type box.
  4. In the File name text box, type C:\My Documents\Customers.txt, and then click Export.
  5. When the Export Text Wizard appears, click Finish, and then click OK.
  6. On the File menu, point to Get External Data, and then click Link Tables.
  7. In the Link dialog box, click Text Files in the Files of type box.
  8. Locate the folder C:\My Documents, select Customers.txt, and then click Link.
  9. On the first three pages of the Link Text Wizard, click Next.
  10. On the last page of the Link Text Wizard, type CustomersLinked in the Linked Table Name box, and then click Finish.
  11. When you receive the message that Microsoft Access has finished linking, click OK.
  12. Quit Microsoft Access.
  13. Open Windows Explorer, and then move C:\My Documents\Customers.txt to another folder.
  14. Start Microsoft Access, and then open the sample database Northwind.mdb.
  15. On the Tools menu, point to Database Utilities, and then click Linked Table Manager.
  16. In the Linked Table Manager dialog box, click to select the CustomersLinked and the Always prompt for new location check boxes, and then click OK.
  17. In the Select New Location of CustomersLinked dialog box, locate Customers.txt in its new location, and then click Open.

    Note that you receive the error message that is mentioned in the "Symptoms" section of this article.

REFERENCES

For more information about linking text files, click Microsoft Access Help on the Help menu, type link a delimited or fixed-width text file in the Office Assistant or the Answer Wizard, and then click Search to view the topic.

Modification Type:MajorLast Reviewed:11/5/2003
Keywords:kberrmsg kbprb KB289611