Player Unable to Download Codecs Through Authenticated Proxy (284852)



The information in this article applies to:

  • Microsoft Windows Media Player 9 Series for Windows XP
  • Microsoft Windows Media Player 9 Series for Windows 2000
  • Microsoft Windows Media Player 9 Series for Windows Millennium Edition
  • Microsoft Windows Media Player 9 Series for Windows 98 Second Edition
  • Microsoft Windows Media Player for Windows XP Home Edition
  • Microsoft Windows Media Player for Windows XP Professional
  • Microsoft Windows Media Player 7.1
  • Microsoft Windows Media Player 7

This article was previously published under Q284852

SYMPTOMS

When you are using a proxy server that requires authentication, if you try to play content that requires a newer codec than you have, you may see a black screen where the video content should be.

CAUSE

Windows Media Player cannot directly download codecs through proxy servers that require authentication. The player must authenticate against the proxy server before it downloads the codec.

WORKAROUND

Before you view the content that requires a codec upgrade, open Windows Media Player, and then open the Event Guide. Your proxy server should prompt you for authentication. After you see the Media Guide content, try to play the audio or video content that requires a newer codec. Because the proxy server has already authenticated Windows Media Player, you can update your codec.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:1/15/2006
Keywords:kbbug kbpending kbui KB284852