Cannot Print or Preview HTML Document Correctly (284274)



The information in this article applies to:

  • Microsoft Internet Explorer 5.5 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 5.5 for Windows Millennium Edition SP 1
  • Microsoft Internet Explorer 5.5 for Windows 98 Second Edition SP 1
  • Microsoft Internet Explorer 5.5 for Windows 2000 SP 1

This article was previously published under Q284274

SYMPTOMS

When you print or preview an HTML document, the document may not appear to be correct, and page breaks may be computed incorrectly.

This behavior does not occur with Internet Explorer 5.01.

CAUSE

This issue can occur with an HTML document that uses a specific sequence of tags (<IFRAME> followed by a <SPAN> block with a STYLE="WIDTH:xxx" attribute) and contains tables.

WORKAROUND

To work around this issue, use any of the following methods:
  • Replace the <SPAN> tag with a <DIV> tag.
  • Add a <BR> tag after the </IFRAME> tag.
  • Add a <H1> tag followed by a </H1> tag after the </IFRAME> tag.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:11/26/2003
Keywords:kbenv kbprb KB284274