You Are Unable to Deny Access to Files in Portal Content Subfolders (284052)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q284052

SYMPTOMS

After you deny access to a document in the Announcements, News, or Quick Links folders, users are still able to view a link to the document when they view the associated Web part in the dashboard site.

After you flush the program level cache, if a user who was denied access connects to the dashboard site home page before any other user, every other user is also be denied access to the item. However, if a user who has access to the document connects before a user who does not have access, then all users are able to view the document, including users who were denied access previously.

CAUSE

This issue occurs because the SharePoint Portal server dashboard site caches items in Portal Content Web parts. By default, the cache is a program level cache that affects all users. You cannot deny access to individual users when the Web parts are using program level caching.

WORKAROUND

To work around this issue, configure the Portal Content Web parts to cache for each user:
  1. Log on as a workspace coordinator, open the dashboard site, and then click the Contents link.
  2. Click the Web part that you want to modify (either Announcements, News, or Quick Links).
  3. Click Show Advanced Settings.
  4. In the Should the content of this Web Part be cached? box, click Per User.
  5. Click Save twice to return to the Home dashboard.
  6. On the Management dashboard, click Flush application level cache.
You are now able to deny access to documents in the Portal Content folders for specific users.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug kberrmsg KB284052