XADM: Store Backup Runs More Slowly as Database Becomes Fragmented (283691)
The information in this article applies to:
- Microsoft Exchange 2000 Server
This article was previously published under Q283691 SYMPTOMS
Over a period of time, as more data is added to an information store database, the performance of the regular online backup decreases. By running a disk analysis tool, you can see that the Priv.edb or Pub.edb file consists of many thousands of fragments.
CAUSE
Whenever an Extensible Storage Engine (ESE) file is extended, it is only extended in 1 megabyte (MB) amounts because ESE is calling a function to ensure that the file size is being updated each time the file is extended. This ensures that administrators can see how big the files currently are.
In addition, an Active Directory attribute which specifies the size of new file extensions is not being observed.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
301378 XGEN: How to Obtain the Latest Exchange 2000 Server Service Pack
The English version of this fix should have the following file attributes or later:
Component: ESE
Component: Information Store
WORKAROUND
Perform an offline defragmentation of the database.
STATUSMicrosoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.
This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.
Modification Type: | Minor | Last Reviewed: | 6/5/2003 |
---|
Keywords: | kbbug kbfix kbQFE KB283691 |
---|
|