OL98: Error Message When You Open a .dat File Attachment in an NDR (276598)



The information in this article applies to:

  • Microsoft Outlook 98

This article was previously published under Q276598

SYMPTOMS

If you receive a non-delivery report (NDR) message in Microsoft Outlook 98 that includes an attachment with a file name that is similar to the Att0001.dat file and you try to open or save the .dat file attachment, you receive the following error message:
The messaging interface has returned an unknown error.

CAUSE

This problem occurs because some NDR messages include a Multipurpose Internet Mail Extensions (MIME) content type that Outlook 98 does not understand. Outlook does not recognize the unknown MIME content type as a text file, and creates the unusable Att####.dat file. This behavior can happen with any unrecognized MIME content type. The "message and delivery-status" (without quotation marks) content type is not recognized in most NDR messages.

RESOLUTION

This problem was corrected in Microsoft Outlook 2000.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The information that describes why the message was not delivered does not convert from the delivery status section of the NDR because it is not data from the original sent message. Data from the original sent message is saved in a separate attachment and is accessible for you to resend.

Modification Type:MajorLast Reviewed:10/21/2000
Keywords:kbbug KB276598