Microsoft OLEDB Cache May Cause the SharePoint Portal Server Client Computer to Run Out of Disk Space (275517)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q275517

SYMPTOMS

Your SharePoint Portal Server client computer has no disk space remaining.

CAUSE

In SharePoint Portal Server, the Microsoft OLE DB cache is restricted to the size of the Microsoft Internet Explorer cache. If the size of the cache is set to a high value, the Microsoft OLE DB cache will grow up to that value. It is possible for the cache size to increase until the SharePoint Portal Server client computer has no disk space remaining.

RESOLUTION

To solve this problem, clear the Microsoft OLE DB cache. The location of the cache depends on the operating system that you are using. The following list contains the locations for each supported operating system:

Microsoft Windows 2000

%Appdata%\Microsoft\Msdaipp\Offline

Note that if there is a service using OLE DB (for example, Microsoft Internet Information Service running Active Server Pages (ASP) scripts that are using OLE DB), the cache is located in the Documents and Settings\Default User\Application Data\Microsoft\Msdaipp\Offline folder.

Microsoft Windows NT 4.0

%Profiles%\username\Application Data\Microsoft\Msdaipp\Offline

Microsoft Windows 98

%Profiles%\username\Application Data\Microsoft\Msdaipp\Offline

If the computer is configured so that users do not have different profiles, the location is:

Windows\Application Data\Microsoft\Msdaipp\Offline

To clear the cache without restarting the computer:
  1. Close all applications.
  2. Open a command prompt.
  3. Click Start, and then click Shut Down.
  4. Simultaneously press CTRL+SHIFT+ALT. While you keep these keys pressed, click Cancel in the Shut Down Windows dialog box.
  5. In the command prompt window, navigate to the cache location, and remove all the content from the Offline folder.
  6. At the command prompt, type explorer, and then press ENTER.
You can also clear the cache by performing the following steps:
  1. Restart the computer.
  2. After restarting, delete the content from the Offline folder before you start any applications.

MORE INFORMATION

Application clients can use OLE DB to access data that is located on both Microsoft FrontPage and HTTP/DAV servers (such as SharePoint Portal Server). The first time the client connects to a server (for example, when you create a Web folders shortcut to a SharePoint Portal Server server), it automatically determines the server type and which protocol to use. The OLE DB client caches the URLs it accesses, and the associated protocols.

Modification Type:MinorLast Reviewed:4/22/2003
Keywords:kbprb KB275517