Picture It!: Error message: An invalid page fault has occurred in module Kernel32.dll (275300)



The information in this article applies to:

  • Microsoft Digital Image Pro 10
  • Microsoft Digital Image Pro 9
  • Microsoft Digital Image Suite 10
  • Microsoft Digital Image Suite 9
  • Microsoft Greetings 2001
  • Microsoft Greetings 2002 1.0
  • Microsoft Picture It! Digital Image Pro version 7
  • Microsoft Picture It! Express 2002 1.0
  • Microsoft Picture It! Express 2001
  • Microsoft Picture It! Express 10
  • Microsoft Picture It! Express 9
  • Microsoft Picture It! Photo version 7
  • Microsoft Picture It! Photo Premium version 7
  • Microsoft Picture It! Photo 2002 1.0
  • Microsoft Picture It! Photo Premium 2002, version 1.0
  • Microsoft Picture It! Photo Premium 2001
  • Microsoft Picture It! Photo 2001
  • Microsoft Picture It! Publishing Platinum 2002 1.0
  • Microsoft Picture It! Publishing 2002, Gold, version 1.0
  • Microsoft Picture It! Publishing 2001 Silver
  • Microsoft Picture It! Publishing 2001 Gold
  • Microsoft Picture It! Publishing 2001 Platinum
  • Microsoft Picture It! Photo Premium 9
  • Microsoft Picture It! Photo Premium 10
  • Microsoft Digital Image Standard Edition 2006
  • Microsoft Digital Image Starter Edition 2006
  • Microsoft Digital Image Suite 2006

This article was previously published under Q275300

SYMPTOMS

When you use one of the programs listed in the "Applies to" section, you may receive one of the following error messages:
An Invalid Page Fault has occurred in module Kernel32.dll.
PIP caused an invalid page fault in module Mmedit5.dll.
Microsoft Digital Image version has encountered an error and needs to close.

CAUSE

This behavior may occur if a driver for any one of the following devices is damaged or is outdated:
  • Printer
  • Scanner
  • Video adapter

RESOLUTION

To resolve this behavior, install the latest driver available for your printer, scanner, and video adapter.

For information about how to contact your printer, scanner, or video adapter manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z



If you install the latest drivers, and the behavior continues to occur, follow these methods.

Use a Different Printer Driver

You may be able to resolve this behavior by using another printer driver.

Note Contact your printer manufacturer to determine which printer driver you can use with your printer.

To change the default printer driver:
  1. Click Start, point to Settings, and then click Printers.
  2. Double-click Add Printer.
  3. Click Next.
  4. Click Local printer, and then click Next.
  5. Under Manufacturers, click the manufacturer of your printer.
  6. Under Printers, click your printer model or the printer model that the manufacturer instructed you to use, and then click Next.
  7. Click LPT1, and then click Next.
  8. Click Yes to make this printer the default printer, and then click Next.
  9. Click No, and then click Finish.

Scanner Drivers

If your scanner has drivers that allows it to use TWAIN, you can scan images directly into Picture It!, Picture It! Photo, or Picture It! Publishing.

If you have more than one scanner driver installed, pick the one you want to use. The Scan Picture command contains the following two scanning options:
  • Custom Scan
  • Smart Task Scan
Smart Task Scan automatically locates your picture, scans it at the correct resolution, and adjusts levels for you. Smart Task Scan can also try to correct the brightness and contrast of your picture. Although you cannot change the Smart Task Scan settings, it's the easiest way to scan pictures if you have a flatbed scanner. If Smart Task Scan does not work correctly or does not produce the result that you want, use Custom Scan.

Custom Scan is for sheet-fed scanners or if you want to modify the image that you are scanning.

Some of the modifications that you can make are presented in the following list:
  • Brightness
  • Contrast
  • Manual cropping
  • Rotating
Note You can use online Help to contact your scanner manufacturer.

Click Help, click Scanner and Digital Camera Help, and then click Finding scanner and digital camera manufacturers on the WWW.

Note Some scanners and scanner drivers do not support the Smart Task Scan feature that is available in the programs listed at the beginning of this article.

After you install the latest scanner driver and confirm with the scanner manufacturer that your scanner supports the Smart Task Scan feature, try to scan a document or image using the Enhanced mode of the Smart Task Scan feature.

Note The Enhanced mode of the Smart Task Scan feature only works with flatbed scanners. If you use a flatbed scanner, the programs listed at the beginning of this article use the Enhanced mode by default.

For additional information about how to troubleshoot a scanner issue, click the following article number to view the article in the Microsoft Knowledge Base:

276552 PI: How to troubleshoot problems when you use a scanner

Video Drivers

If a video driver is causing the issue to occur, you may be able to work around this issue by changing the hardware acceleration setting for your video adapter.

To change the hardware acceleration setting:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. On the Performance tab, click Graphics.
  4. Move the Hardware Acceleration slider to None.
  5. Click OK, and then click Close.
  6. Click Yes, to restart the computer.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:9/28/2005
Keywords:kberrmsg kbprb KB275300