Lotus Notes Discovery Causes Problems with Cdir_ln.exe (275288)



The information in this article applies to:

  • Microsoft Metadirectory Services 2.1
  • Microsoft Metadirectory Services 2.2

This article was previously published under Q275288

SYMPTOMS

When you are discovering the Lotus Notes address book by using the Notes client version 4.6.2, Cdir_ln.exe may stop responding (hang) or quit randomly.

CAUSE

Cdir_ln.exe does not process binary timestamp attribute values correctly. It attempts to interpret the data as multiple-lined text strings, which causes problems with the Notes functions. In one example, a single record in a large address book (with more than 100,000 records) contained data of type "date-time" in the "shortname" field. This caused the Cdir_ln.exe program to quit randomly during the discovery process.

RESOLUTION

NOTE:The QFE patch associated with this article has been superceded by Q285852.EXE. However, the content in this article remains valid.
In order to access the fix referred to in this article, please refer to:

285852 Replacement QFE for MMS 2.2

NOTE: This issue affects Microsoft Metadirectory Services (MMS) versions 2.1 and 2.2. However, this hotfix was written for MMS 2.2 only. To resolve this issue in MMS 2.1, upgrade to MMS 2.2 and then apply the hotfix.

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next version of Microsoft Metadirectory Services that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date        Time   Version     Size       File name
   ---------------------------------------------------------
   10/25/2000  02:48  2.2.1187.0    890,880  Cdir_ln.exe
   08/25/2000  20:35  2.2.0.1124  1,126,912  Viaserver.exe
   09/15/2000  17:03  2.2.0.1124    896,000  Mmshashtool.exe
   08/25/2000  20:35  2.2.0.1124  1,503,744  Replica.exe
   09/15/2000  17:02  2.2.0.1124  1,126,912  Viaserver.exe
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/12/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB275288