Repeated prompts for user name and password with Digest Authentication (275123)
The information in this article applies to:
- Microsoft FrontPage 98 for Windows
- Microsoft FrontPage 97 for Windows
This article was previously published under Q275123
For a Microsoft FrontPage 2000 and Microsoft FrontPage 2002 version of this article, see 291373.
SYMPTOMS
When you attempt to use Microsoft FrontPage 97 or Microsoft FrontPage 98 to author a Web site that uses Digest Authentication, you are continually prompted for a user name and password.
NOTE: Microsoft Internet Information Services (IIS) versions 5.0 and later can use a form of Internet security called Digest Authentication, which is defined in RFC 2069. For more information, see the "References" section later in this article.
CAUSE
Although Microsoft Internet Explorer versions 5.0 and later can use Digest Authentication, FrontPage 97 and 98 do not support this type of authentication.
WORKAROUND
To work around this behavior, use one of the following authentication methods:
- Windows Integrated Security on Microsoft Windows 2000.
- Windows NTLM on Microsoft Windows 95, Microsoft Windows 98, Microsoft Windows Millennium Edition (Me), and Microsoft Windows NT 4.0.
- Basic/Clear Text on all versions of Windows.
Note Basic authentication should be used only with SSL to secure user names and passwords. STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.REFERENCES
For more information about Digest Authentication, click the following article numbers to view the articles in the Microsoft Knowledge Base:
264921
How IIS authenticates browser clients
222028 Setting Up Digest Authentication for use with Internet Information Services 5.0
To view the specification for Digest Authentication, see the following:
RFC 2617 HTTP Authentication: Basic and Digest Access Authentication
Modification Type: | Major | Last Reviewed: | 7/3/2006 |
---|
Keywords: | kbbug kbnofix KB275123 |
---|
|