ACC2002: "Record Is Deleted" Error After Synchronization (275113)



The information in this article applies to:

  • Microsoft Access 2002

This article was previously published under Q275113
Moderate: Requires basic macro, coding, and interoperability skills.

This article applies only to a Microsoft Access database (.mdb).

For a Microsoft Access 2000 version of this article, see 270116.

SYMPTOMS

When you try to save a record in a replica, you may receive the following error message:
Record is deleted.

CAUSE

This error occurs when you try to save a record and both of the following conditions are true:

A synchronization between replicas is occurring while a record is being edited.

-and-

The Default Record Locking option is set to No locks.

RESOLUTION

Make sure that each replica has saved all changes to records before synchronization begins and that no further edits are attempted until the synchronization is finished.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Steps to Reproduce the Behavior

CAUTION: If you follow the steps in this example, you modify the sample database Northwind.mdb. You may want to back up the Northwind.mdb file and follow these steps on a copy of the database.

  1. Open the sample database Northwind.mdb.
  2. On the Tools menu, click Options. Click the Advanced tab, and under Default record locking, click No Locks.
  3. On the Tools menu, point to Replication, and then click Create a Replica.
  4. In the Design Master, open the Customers table, and then modify the ContactName field for CustomerID ALFKI, changing the name Maria to Mary.
  5. Close the Customers table.
  6. Open a second instance of Access, and then open the replica that you created in step 3.
  7. Open the Customers table and edit the same ALFKI record, but do not commit the changes.
  8. Switch back to the first instance of Access.
  9. On the Tools menu, point to Replication, and then click Synchronize Now. Select the Directly with Replica option, select the replica that you created in step 3, and then click OK.
  10. Click Yes when you are prompted to close the database prior to synchronization, and then click OK if you are prompted that the synchronization was successful.
  11. If the synchronization was successful, switch back to the second instance of Access, and try to commit the record that you began editing earlier. Note that you receive the error message mentioned in the "Symptoms" section of this article.

Modification Type:MajorLast Reviewed:11/6/2003
Keywords:kbbug kberrmsg kbnofix KB275113