XADM: Upgrade to Exchange 2000 Does Not Work If the Exchange Server 5.5 Machine Account Is Changed (271346)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q271346
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you upgrade Microsoft Exchange Server 5.5 to Exchange Server 2000, you receive an error message when you attempt to install the Exchange Administrator tools. If you click Retry, the situation does not change, and if you click Cancel, the upgrade process stops.

CAUSE

The upgrade from Exchange Server 5.5 to Exchange 2000 does not work because the domain membership of the Exchange Server 5.5 machine account was changed.

For example, the machine account for the Exchange Server 5.5 computer was initially created in Domain1, and then later configured to belong to Domain2.

The upgrade stops working while trying to register the Exadmin.dll file in the registry because the Regsrv32.exe process stops responding while it is searching for the old domain. The Exchange Server 5.5 Administrator program caches the previous domain that the server belongs to. This setting is cached in the registry at the following location:

HKEY_CURRENT_USER\Software\Microsoft\Exchange\MSExchangeAdminCommon
PermissionDefaultDomain = Old Domain

WORKAROUND

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


When you receive the error message:
  1. Open Task Manager, and stop the Regsrv32 process.
  2. Remove the registry key which caches the domain information.
Removing the registry key allows the upgrade to complete the installation of the Administrative components.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug kbpending KB271346