Windows Media Encoder Does Not Work During a Terminal Services Client Session (269393)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 Terminal Server Edition
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Datacenter Server
This article was previously published under Q269393 SYMPTOMS
When you use Windows Media Encoder during a Terminal Services session,
you may receive the following error message:
No audio input devices detected, therefore live capture options have been disabled.
After you click OK, you receive the following message:
You must have audio codes installed in order to use this application.
In addition, if you are using sound programs which require access to sound cards, you may also receive the same error messages.
CAUSE
This issue occurs because Terminal Services turns off all audio redirection for Remote Desktop Protocol (RDP) clients. Because of Terminal Services' all-or-nothing design, no sound devices are enumerated during a client session. This behavior is by design.
RESOLUTION
To work around this issue, use Microsoft Netmeeting, since this software supports audio devices.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 1/20/2006 |
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Keywords: | kberrmsg kbprb KB269393 |
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