Visual Studio installation problems occur if Crystal Reports 8 is installed (268553)
The information in this article applies to:
- Microsoft Visual Studio, Enterprise Edition 6.0
- Microsoft Visual SourceSafe for Windows 6.0
- Microsoft Visual FoxPro for Windows 6.0
- Microsoft Visual FoxPro for Windows 7.0
- Microsoft Visual C++, 32-bit Editions 6.0
- Microsoft Visual Basic Professional Edition for Windows 6.0
- Microsoft Visual J++ 6.0
- Microsoft Visual InterDev 6.0
- Microsoft Office Developer's Kit (ODK), when used with:
- the operating system: Microsoft Windows 2000
- the operating system: Microsoft Windows NT 4.0
- the operating system: Microsoft Windows XP
- Microsoft Office XP Developer
- Microsoft Visual Studio .NET (2002), Academic Edition
- Microsoft Visual Studio .NET (2002), Enterprise Architect Edition
- Microsoft Visual Studio .NET (2002), Enterprise Developer Edition
- Microsoft Visual Studio .NET (2002), Professional Edition
- Microsoft Visual Studio .NET (2003), Academic Edition
- Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
- Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
- Microsoft Visual Studio .NET (2003), Professional Edition
- Microsoft Visual Studio 2005 Professional Edition
- Microsoft Visual Studio 2005 Standard Edition
This article was previously published under Q268553 SYMPTOMS
When you install Microsoft Visual Studio products on a computer that has Crystal Reports version 8 from Business Objects installed, you receive one of the following error messages:
Message 1
setup error 168
Message 2
setup error failed to register d:\program files\common files\designer\ msaddndr.dll
Message 3
setup was not completed successfully, please reinstall
Message 4
Cannot register msxml3.dll
Message 5DLL Name was unable to register itself in the system registry
Note This series of errors has been found to occur during both the product installation and the application of the product service packs.
CAUSE
The third-party program, Crystal Reports, has removed registry permissions from the affected keys.
RESOLUTION
You can use the following procedure to resolve this problem:
- Start Regedt32.
- Browse to each of the following keys:
HKEY_CLASSES_ROOT\TypeLib\{000204EF-0000-0000-C000-000000000046}\6.0\9\win32
HKEY_CLASSES_ROOT\TypeLib\{AC0714F2-3D04-11D1-AE7D-00A0C90F26F4}\1.0\0\win32
HKEY_CLASSES_ROOT\TypeLib
HKEY_CLASSES_ROOT\Interface
HKEY_CLASSES_ROOT - Select each key. From the Security menu, click Permissions.
- Make sure that the local computer's Administrators group has full control. Also select Allow inheritable permissions from parent to propagate to this object or, on Microsoft Windows NT, Replace permission on existing subkeys.
- Click Apply.
- Click Run.
REFERENCES
For additional information about the registry problems that are caused by Crystal Reports, click the following article number to view the article in the Microsoft Knowledge Base:
272693
0x80004005 ASP error message occurs when you connect to a database after Crystal Reports 8 installation
For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
259569
PRB: Installing third-party product breaks Windows 2000 MDAC registry settings
269383 PRB: 'Error accessing the system registry' message when displaying VB/VBA references
266621 PRB: Error "library not registered" with Crystal Reports 8.0
Modification Type: | Major | Last Reviewed: | 1/19/2006 |
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Keywords: | kbvs2005applies kbvs2005swept kbprb KB268553 kbAudDeveloper |
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