PRB: System Stops Responding at Startup When Password or User Info Are Enabled (260315)



The information in this article applies to:

  • Microsoft Windows CE Platform Builder 2.11
  • Microsoft Windows CE Platform Builder 2.12

This article was previously published under Q260315

SYMPTOMS

If startup screens for owner information or password are enabled, Windows CE may stop responding (or hang) at startup with a blank or grey screen showing on the display.

CAUSE

A deadlock condition can occur as the Graphics, Windowing, and Events Subsystem (GWES) starts up. The GWES makes a call to the soft input panel (SIP) driver, which in turn waits for the GWES to complete initialization.

RESOLUTION

There are two ways to work around this problem:
  • Remove SIP support.

    SIP support is provided by the Softkb.dll module. To remove SIP support, edit the Cesysgen.bat file for your platform and remove "softkb" from the CE_MODULES definition. Platform Builder 2.12 users must close and reopen the platform workspace after making this change.

  • Provide a default input method.

    The problem does not occur if a default input method is defined in the following registry key:

    HKEY_CURRENT_USER\ControlPanel\Sip
    							

    A sample default input method is provided in Platform Builder. To activate it, set the TESTSIP environment variable before building the ROM image.

Modification Type:MinorLast Reviewed:12/27/2003
Keywords:kbprb KB260315