Error Message: You Do Not Have Sufficient Access to Your Machine to Connect to the Selected Printer (259937)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

This article was previously published under Q259937

SYMPTOMS

When you attempt to connect to a printer while you are connected to a Windows 2000-based server that is running Terminal Services by using the Remote Desktop Protocol (RDP) client, you may receive the following error message:
You do not have sufficient access to your machine to connect to the selected printer.

CAUSE

The Prevent users from installing printer drivers option is enabled by default in the local security settings.

RESOLUTION

On the server running Terminal Services:
  1. Click Start, point to Programs, click Administrative Tools, and then double-click Local Security Policy.
  2. Double-click Local Policies.
  3. Double-click Security Options.
  4. In the right pane, double-click Prevent users from installing printer drivers.
  5. Click Disabled, and then click OK.
  6. Close the Local Security Settings window.
It may be necessary to reboot the server or to force an immediate policy refresh for the change to take effect. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

227302 Using Secedit to Force a Group Policy Refresh Immediately

MORE INFORMATION

In a domain environment, administrators may want to change this policy at the domain or organizational unit level, rather than on each server running Terminal Services. This error message does not occur if the server running Terminal Services is a domain controller.

Modification Type:MajorLast Reviewed:11/4/2003
Keywords:kberrmsg kbprb kbprint kbTermServ KB259937