SYMPTOMS
When you are trying to use Microsoft Data Access Components
(MDAC) in your applications, you may receive one of the following error
messages:
Error in the DLL.
Provider can not be found. Ensure that the
provider has been installed properly.
Data Source Name not found or no default
driver specified.
CAUSE
The registry settings for MDAC components have been altered
to reflect incorrect version information for older versions of MDAC or
permissions have been modified on MDAC related keys in the registry. Currently,
the products known to cause this problem are Cold Fusion (when installing the
advanced security features) and Crystal Reports Web Server 8.
NOTE:
The
third-party products that are discussed in this article are manufactured by
companies that are independent of Microsoft. Microsoft makes no warranty,
implied or otherwise, regarding the performance or reliability of these
products.
Workarounds for Products Known to Cause This Problem with MDAC
Cold Fusion 4.5 After installing Cold Fusion 4.5 with the Advanced
Security Features, you begin to receive one of the error messages:
Error in DLL
Provider can not be found. Ensure that the
provider has been installed properly.
Currently the only way to
correct the problem is to reinstall the operating system. You can choose the
Upgrade option to retain all your applications and settings.
Crystal Reports 8 After installing Crystal Reports 8, you begin to
receive the error:
Data Source Name not found or no
Default driver specified.
Ensure that the Data Source Name (DSN)
that you are referencing does exist. If you are developing an ASP page, ensure
that your DSN is a System DSN, not a User DSN.
- On the Start menu, click Run, and then type regedt32 in the Run window to open the program.
- On the HKEY_Local_Machine window, browse down to the folder ODBC located at:
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI
- Click on the DSN you have created, and then click on the Security menu item and choose Permissions. Make sure that the appropriate account has permission to this
registry key.
RESOLUTION
On Microsoft Windows 2000, the resolution is to reinstall
the Operating System. Simply start the setup of Windows 2000, select the
UPGRADE Option, and the installation process corrects all corrupted
registry settings. All the applications and files remain intact.
On
a Microsoft Windows NT 4 computer, you can reinstall any version of MDAC that
is currently available for download at the following Microsoft Web
site:
REFERENCES
For additional information, click the article number
below to view the article in the Microsoft Knowledge Base:
272693 0x8004005 ASP Error Message Occurs When You Connect to a Database after Crystal Reports 8 Installation