You receive server error messages when you try to add a user to the permissions on the root web of your Web site (259534)



The information in this article applies to:

  • FrontPage 2000 Server Extensions from Microsoft, when used with:
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT

This article was previously published under Q259534

SYMPTOMS

When you try to add a new user to the permissions on the root web of your Web site, FrontPage stops responding with the following error message:
Server Error: Error occurred while returning the list of users from the system.
When you click OK, the following error message appears:
An error occurred accessing your FrontPage web files. Authors if authoring against a web server please contact the webmaster for this web servers site. Webmasters please see the servers system log for more details.
On the server in the System Log, one of the following error messages appears:
No Windows NT or Windows 2000 Domain Controller is available for domain DomainName. The following error occurred:

There are currently no logon servers available to service the logon request.
-or-
The server was unable to logon the Windows NT account 'username' due to the following error: Logon failure: unknown user name or bad password. The data is the error code.

For additional information specific to this message please visit the Microsoft Online Support site located at:

http://search.support.microsoft.com/search/?adv=1.
In the Security Log, the following error message appears:

Logon Failure:
 	Reason:		Unknown user name or bad password
 	User Name:	username
 	Domain:		domainname
 	Logon Type:	2
 	Logon Process:	IIS     
 	Authentication Package:	MICROSOFT_AUTHENTICATION_PACKAGE_V1_0
 	Workstation Name:	servername
					
In the Application Log, the following error messages appear:
Microsoft FrontPage Server Extensions:
   http://servername - Error #20001 Message: Cannot open file
 "c:\inetpub\wwwroot\subweb1\_vti_pvt\access.cnf" for reading.
					
-and-

Microsoft FrontPage Server Extensions:

(OS Error #13 Message: Permission denied)
-and-

Microsoft FrontPage Server Extensions:

http://servername - Error #80002 Message: System exception: access violation.
-and-

Microsoft FrontPage Server Extensions:

(OS Error #-1073741819 Message: exception occurred at 0x67f333e4)
-and-

Microsoft FrontPage Server Extensions:

Received empty response from Microsoft FrontPage Server Extensions

CAUSE

This problem occurs when there is a subweb that is using unique permissions, and your account does not have explicit access to that subweb. The server extensions are attempting to access information in the _vti_pvt folder of the subweb that is using unique permissions.

WORKAROUND

To work around this problem, use one of the following methods.

NOTE: These two methods should be applied only if you are experiencing this problem. These are temporary workarounds until this problem can be addressed.

Method 1

Explicitly give your FrontPage administrative users at least browse access to all webs that use unique permissions.

Method 2

Follow these steps:
  1. Click Start and then click Run.
  2. In the Open box, type cmd and then click OK.
  3. Change the directory to the folder above your content (for example, c:\Inetpub).
  4. Run the following command:

    cacls foldername /t /e /r interactive network

    where foldername is the name of the folder that contains your content.


This command revokes the permissions for the interactive and network groups on the content. If you run "Check Server Extensions" and choose to tighten security, you must repeat steps 1 through 4.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kbpermissions kbweb kberrmsg kbprb kbpending KB259534