XADM: Error c103aa66 or c1031bd1 When Saving Active Directory Connector Connection Agreement (259518)



The information in this article applies to:

  • Microsoft Windows 2000 Server

This article was previously published under Q259518

SYMPTOMS

When you save a connection agreement with the Active Directory Connector (ADC) Microsoft Management Console (MMC) snap-in, you may receive one of the following error messages:
  • An error has occurred while saving the Connection Agreement credentials with the security authority on the responsible ADC server for this Connection Agreement. Please ensure that the account you are logged in as has the permissions to administer the ADC service.

    ID no: c1031bd1
    Microsoft Active Directory Connector Management
    An error has occurred while saving the Connection Agreement credentials with the security authority on the ADC server responsible for this Connection Agreement. Please ensure that the account you are logged in as has the permissions to administer the ADC Service and that the ADC Service has been started as a member of the built-in Administrators security group.

    ID no: c103aa66
    Microsoft Active Directory Connector Management

CAUSE

This issue can occur if either of the following conditions exist:
  • The account that is being used to run the ADC service is not a member of the built-in Administrators group.
  • The ADC service was not restarted after the account that is being used to run the ADC service was added to the built-in Administrators group.

RESOLUTION

To resolve this issue, verify that the service account for the ADC is in the built-in Administrators group, restart the ADC service, and then save the connection agreement.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB259518