Allegiance Error Message: Failed to Connect to the Lobby (259457)



The information in this article applies to:

  • Microsoft Allegiance 1.0

This article was previously published under Q259457

SYMPTOMS

When you click Free Games and then click Games List, you may receive the following error message:
Failed to Connect to the Lobby.

CAUSE

This issue may occur if any of the following conditions are true:
  • You connect to the Allegiance game server through a proxy server or firewall.
  • You connect to the Allegiance game server by using Microsoft Windows 98 Internet Connection Sharing (ICS) or Network Address Translation (NAT).
  • You are experiencing high Internet latency.
  • The Allegiance browser server for public games is unavailable.

RESOLUTION

To resolve this issue, use the following methods in the order that they appear. If the issue continues to occur, continue to the next method or try connecting to Free Games at another time.

Install the Latest Version of DirectX

To download and install the latest version of DirectX, visit the following Microsoft Web site:

Configure the Proxy Server or Firewall

For additional information about how to configure a proxy server or firewall for use with Allegiance, click the article number below to view the article in the Microsoft Knowledge Base:

240429 DirectX: Ports Required to Play on a Network

Use a Direct Internet Connection

If you connect to the Allegiance game server by using Microsoft Windows 98 Internet Connection Sharing or other forms of NAT, connect directly to the Internet instead. Allegiance is not compatible with Windows 98 Internet Connection Sharing and some other forms of NAT.

MORE INFORMATION

For additional information about troubleshooting network issues, click the following article number to view the article in the Microsoft Knowledge Base:

819836 Games: How to Troubleshoot Multiplayer Issues


Modification Type:MajorLast Reviewed:7/21/2003
Keywords:kberrmsg kbnetwork kbprb KB259457