ACPI Computer with Anti-Virus Software Installed Stops Responding When You Restart Computer (259253)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition

This article was previously published under Q259253

SYMPTOMS

When you restart your computer and Advanced Configuration and Power Interface (ACPI) is enabled, the computer may stop responding (hang) if you use either of the following methods to restart the computer:

Method 1
  1. Click Start, click Shutdown, and then click Restart in the Shut Down Windows dialog box.
Method 2
  1. Click Start, click Shutdown, and then click Restart in MS-DOS mode in the Shut Down Windows dialog box.
  2. After the MS-DOS prompt is displayed, type exit to restart Windows.
After the computer hangs, you must turn off and turn on the computer.

This problem has been observed on computers with Windows Driver Model (WDM) drivers installed (such as those supporting WHQL-compliant audio devices), along with anti-virus software that performs security checks during system shutdown.

CAUSE

During system shutdown, the virtual math coprocessor device (Vmcpd.vxd) can incorrectly leave the Task Switched (TS) bit set in the CR0 register. When you restart the computer, real-mode initialization of the Floating Point Unit (FPU) results in an exception that is handled by an uninitialized interrupt. This results of an endless retry of the opcode that initiated the interrupt.

This problem can occur after the Windows Virtual Machine (VM) hangs when anti-virus software interacts with WDM driver event processing.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:
   Date        Time     Version    Size    File name  Operating system
   -------------------------------------------------------------------
   05/02/2000  11:31am  4.10.2223  22,615  Vmcpd.vxd  Windows 98 
                                                      Second Edition
				

STATUS

Microsoft has confirmed that this is a problem in Windows 98 Second Edition.

MORE INFORMATION

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kbfix kbQFE KB259253