SBS Fax "Query Returns No Records" Message After Filling Drive to Capacity (259040)
The information in this article applies to:
- Microsoft BackOffice Small Business Server 4.0
- Microsoft BackOffice Small Business Server 4.0a
- Microsoft BackOffice Small Business Server 4.5
This article was previously published under Q259040 SYMPTOMS
When you are using the SBS console in BackOffice Small Business Server (SBS), clicking the Generate Fax Report link (under More Tasks and Manage Faxes) may return an empty report and the following message may be displayed:
Your query did not return any records, so there is nothing to display.
However, faxes are sent successfully and the following events are
logged for the NTFax service in the Application event log on the SBS server:
Event ID 8214 Fax sent to spooler
Event ID 8204 Fax sent successfully
CAUSE
This behavior occurs when the Fax Sent Report tool looks for information that is contained in the Event Viewer logs but that has not been parsed and saved correctly in the two .csv files from which the report reads its displayed information. This can be caused by any of the following items:
- All or part of the event logs files are corrupted.
- The temporary report files (Faxin.csv and Faxout.csv) are corrupted.
- Either the event logs or the .csv files are fragmented sufficiently to prevent reading and returning information within a thread time-out period.
This behavior can occur if a drive, partition, or volume has been filled to capacity, and files are then moved or deleted without defragmenting the drive, partition, or volume. Subsequent files are often not saved in contiguous sectors, and the Master File Table (MFT) is being used to store multiple file fragments larger than its standard 4-KB size.
Before using the resolution listed below, first verify that fax events exist in the event log and that they are being written to the Faxin.csv and Faxout.csv files in the SmallBusiness\HTML\Logs folder.
If the files show a 0-byte size, the data in the event log is not being extracted and/or saved properly to the .csv files. This could be caused by corrupted or fragmented event logs, or by the inability to properly write the .csv files because of a lack of file space or by corrupted, highly fragmented, or limited MFT space.
If the .csv files are larger than 0 bytes, the issue may still be caused by the .csv files being highly fragmented and timing out when being read. Check this by importing the .csv file into another parser such as Microsoft Word. If the .csv file is loaded successfully, the problem is more likely to be found in the tool or query processor.
RESOLUTION
When a drive or partition is filled completely (or to the point at which the MFT is used for file space for files larger than 4 KB), the only permanent solution is to make a complete backup of the drive or partition and then repartition and format the entire physical disk. Then, restore the system to its prior state from the backup.
Workarounds or short-term fixes to get a system running again include some or all of the following methods as circumstances permit:
- Move the Temp folder to another another drive.
- Move data folders to another drive.
- Move or delete unnecessary Memory.dmp and User.dmp files.
- Move the Pagefile.sys file to another drive.
NOTE: If the Pagefile.sys file is absent on the system partition, or is smaller than the existing RAM size, a memory dump file is not written to disk in the event of a system crash. - If you cannot move the paging file (Pagefile.sys), match the maximum and minimum sizes to reduce further file fragmentation. This does not affect the internal structures of the file because it is not written contiguously by design.
- After you make as much space available as possible, run a file defragmentation program to create contiguous blocks of free space.
WARNING: Before using any program for file defragmentation on any version of SBS, verify that the program is designed specifically to work with SBS, or at minimum that it is designed for the NTFS files system running on Microsoft Windows NT Server 4.0 or later. Do not use any defragmentation software included with or designed specifically for Microsoft Windows 95 or Microsoft Windows 98 to defragment any version of SBS or data corruption and/or data loss could occur.
Without recommending any specific third-party product, examples of this type of software include Symantec Norton SpeedDisk and Executive Software Diskeeper.
A 30-day, no-charge trial copy of Diskeeper is available for download at:
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products. MORE INFORMATION
When you start the Fax Reporting tool to generate a fax report, a process queries and parses the event log for specific fax-related event IDs. That information is then saved in the .csv files.
The Fax Reporting tool actually displays the catalog information read from the .csv files, not by directly reading the event log.
REFERENCESFor additional information about verifying fax logging settings and how to verify if fax entries are actually logged in the event log, click the article numbers below
to view the articles in the Microsoft Knowledge Base:
236425 SBS: Fax Report Is Empty
172156 How to Delete Corrupt Event Viewer Log Files
Modification Type: | Major | Last Reviewed: | 11/19/2003 |
---|
Keywords: | kbenv kberrmsg kbprb KB259040 |
---|
|