Re-creating Missing DSA Attributes After VIACompact Rebuilds the DSA Record (258003)



The information in this article applies to:

  • Microsoft Metadirectory Services 2.1

This article was previously published under Q258003

SYMPTOMS

The DSA record in the metadirectory may lose particular attributes. The following table is a partial list of the attributes that may be missing when you run a "View all attributes" query on the DSA record.

Attribute functionAttribute names
server logszcServerLog & zcServerLogControl
available MA typeszcZoomitMAs & zcZoomitMAsControl
MA zscript logszcServerZscriptLog & zcServerZscriptLogControl
Default client access methodsuggestedSASLMechanism
replication logszcServerRepLog & zcServerRepLogControl
custom MA typeszcSiteMAs & zcSiteMAsControl
server BAK logszcServerLogBak & zcServerLogBakControl
database configurationzcDb5Configuration & zcDb5ConfigurationControl
server naming contextzcNamingContext
DSA object read permissionszcOwnReadPermissions
DSA object write permissionszcOwnModifyPermissions
dsa access protocolssupportedSASLMechanisms

CAUSE

This behavior can occur after a missing DSA record has been automatically reconstructed by VIACompact.

RESOLUTION

To restore the missing attributes to the DSA record:
  1. Stop the server.
  2. In the Zoomserv\Bin\Init folder, type ..\importt -updatedib -updateallattributes.
If the icons on the Action bar for the DSA are missing (that is, there is no Configure the management agent icon:
  • Stop the server.
  • In the Zoomserv\Bin\Init\Methods folder, type loadmeth.bat.

MORE INFORMATION

Other indications of a missing DSA record include the ability to log on to the server by using HTTP, but not LDAP. This occurs because the security verification methods for HTTP, unlike LDAP, do not access the DSA record.

Modification Type:MajorLast Reviewed:10/3/2003
Keywords:kbenv kbprb KB258003