Small Business Server Move Folder Wizard May Stop Responding (255955)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q255955

SYMPTOMS

When you use the Small Business Server (SBS) Move Folder Wizard, you may receive one of the following error messages:
An error has occurred while moving the folder. Not all files or subfolders have been moved.

-or-

Unable to move selected folder.
Some of the files have been moved or copied, but the original share is removed. A new share is created, but not all of the files are moved.

CAUSE

This behavior can occur in any of the following scenarios:
  • A shared folder exists in the folder that is being moved.
  • The administrator account does not have full control of all files and folders that are being moved.
  • The combined length of the folder paths is longer than 256 characters. (Individual files in the folder do not count towards this total.)
  • A folder with the same name as the folder that is being moved already exists in the destination folder.

RESOLUTION

To resolve this issue, manually repair the resulting file structure. To do so, use Windows Explorer to locate the original folder, and then manually copy it to the new location. When you are prompted to overwrite existing files, click Yes to all.

MORE INFORMATION

When you move the folder to another disk drive, permissions on the new files are inherited from the destination folder. If you want to use custom NTFS file system permissions, manually assign permissions to individual files and subfolders.

If permissions have been changed on any files or folders to specifically deny access to the system administrator account, or if access control lists (ACL) have been set to remove the system administrator or system accounts from the resource, you need to take ownership of the file or folder, and then manually assign permissions.

In some cases, you may need to take ownership of the folder, individual files, or subfolders to successfully move the folder contents to the new location. For example, if the C:\Documents folder is shared as \\server\docs, and share permissions are set to Everyone: Full Control, if a user has applied custom NTFS permissions to their files, the following files are present in the folder:

File NameNTFS Permissions
C:\Documents\File1.docEveryone: Full Control
C:\Documents\File2.docEveryone: Full Control
C:\Documents\File3.docEveryone: Full Control
C:\Documents\File4.docEveryone: No Access
User1: Full Control

When you move the C:\Documents folder to the D: drive partition to free some disk space on your C: drive partition, the Move Folder Wizard may stop responding during the move. A new share is created on the D: drive partition, and all documents except File4.doc are moved successfully. To move the remaining file, follow these steps:
  1. Log on to the server as a system administrator.
  2. Use Windows Explorer to take ownership of File4.doc.
  3. Copy File4.doc to the D:\Documents folder. Verify that User1 is able to access the file.
  4. Delete the C:\Documents folder and its contents.
For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

174273 How to Copy Files and Maintain NTFS and Share Permissions


Modification Type:MajorLast Reviewed:9/20/2006
Keywords:kbenv kberrmsg kbprb KB255955