Error Message: MDAC Install Was Unsuccessful (255653)
The information in this article applies to:
- Microsoft Expedia Streets and Trips 2000
- Microsoft Home Publishing 2000
- Microsoft Works Suite 2000
This article was previously published under Q255653 SYMPTOMS
When you attempt to install one of the programs listed at the beginning of this article, you may receive the following error message
MDAC install was unsuccessful.
or you may receive an error message similar to the following:
Filename was not installed properly.
CAUSE
This behavior can occur if Microsoft Data Access Components (MDAC) is not installed properly or is damaged.
RESOLUTION
To resolve this issue, manually extract the MDAC files to the Windows\System folder, and then reinstall the Mdac_typ.exe file while your computer is in Safe mode. To do this, use the following methods in the order in which they are presented.
Back Up the Windows\System Folder
To back up the Windows\System folder:
- Click Start, and then click Run.
In the Open box, type the following line, and then click OK
where drive is the drive letter of the hard disk on which Microsoft Windows is installed.
- Right-click the System folder, and then click Copy.
- Right-click a blank area inside the Windows folder, and then click Paste to paste a folder named Copy of System inside the Windows folder.
- Right-click the Copy of System folder, and then click Rename.
- Type sysold, and then press ENTER.
- Quit Windows Explorer.
Copy and Extract the Mdac_typ.exe FileCopy the Mdac_typ.exe File to the Windows Desktop
Copy the Mdac_typ.exe file to the Windows Desktop from the appropriate path for your program:
Expedia Streets and Trips 2000:cdrom:\common\enu
where cdrom is the drive letter of your CD-ROM drive.
Microsoft Works Suite 2000:cdrom:\redist\mdac
where cdrom is the drive letter of your CD-ROM drive.
Microsoft Home Publishing 2000:cdrom:\MHP\redist\mdac
where cdrom is the drive letter of your CD-ROM drive.
Extract the MDAC Files
To extract the MDAC files:
- Click Start, point to Programs, and then click MS-DOS Prompt.
- At the command prompt, type the following lines, and then press ENTER after you type each line:
cd c:\windows\desktop
mdac_typ.exe /c /t:c:\mdactemp
exit
NOTE: These steps automatically create a folder named Mdactemp.
- Click Start, and then click Shut Down.
- Click Restart in MS-DOS mode, and then click OK.
Copy the Extracted Files to the Windows\System Folder
To copy the extracted files to the Windows\System folder:
- At the command prompt, type the following lines, and then press ENTER after you type each line:
cd c:\mdactemp
copy *.dll c:\windows\system - Press CTRL+ALT+DELETE to restart the computer.
Restart the Computer in Safe Mode
To restart the computer in Safe mode, use the appropriate method for your version of Microsoft Windows.
Microsoft Windows 95
When you see the "Starting Windows 95" message, press the F8 key, and then choose Safe Mode from the Startup menu.
Microsoft Windows 98
Press and hold down the CTRL key after your computer completes the POST (Power on Self Test), and then choose Safe Mode from the Startup menu.
Reinstall the Mdac_typ.exe File
To reinstall the Mdac_typ.exe file:
- When the computer is in Safe mode, double-click the Mdac_type.exe file.
- Follow the instructions on the screen to reinstall the Mdac_type.exe file.
- Restart the computer.
Modification Type: | Major | Last Reviewed: | 6/30/2004 |
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Keywords: | kberrmsg kbprb KB255653 |
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