XADM: Information Store Stops Responding with Event ID 1220 (255037)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q255037

SYMPTOMS

The Exchange Server information store may stop responding and an event ID 1220 may be logged in the application event log. The description of the event is as follows:
Internal server error: database session was not released by previous request.

CAUSE

This problem can occur if a mailbox has an unusually deep folder hierarchy (approximately 2,000 folders or more) and trying to delete it causes a stack overflow in JET.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server 5.5 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

Component: Information Store

File nameVersion
Store.exe5.5.2651.89

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5.

Modification Type:MinorLast Reviewed:10/7/2005
Keywords:kbbug kbfix KB255037