Fragmentation of Multicast UDP Packets May Cause Performance Degradation and Packet Loss (252360)
The information in this article applies to:
- Microsoft Windows Media Tools 4.0
- Microsoft Windows Media Tools 4.1
This article was previously published under Q252360 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
Fragmentation and packet loss may occur when you deploy high bit-rate Windows Media content.
CAUSE
Windows Media Server can generate UDP packets that are greater than 1500 bytes when you deploy high bit-rate content. This can cause IP packets to be fragmented for Windows Media Server streams because Ethernet packets have a maximum size of 1500 bytes. Fragmentation can cause performance degradation and packet loss.
RESOLUTIONA supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Media service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
Date Time Version Size File name Platform
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12/09/1999 06:24p 1,021,136 NsRex.exe x86
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 10/6/2005 |
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Keywords: | kbHotfixServer kbQFE kbdownload kbbug kbfix kbQFE KB252360 |
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