Autologon for Terminal Server Clients Does Not Work (248645)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition

This article was previously published under Q248645
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to use autologon to gain access to Terminal Server, you may not be able to do so.

CAUSE

This behavior can occur when the value for the following registry key is incorrect:
HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon\DontDisplayLastUserName
				

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


To resolve this issue, change a value in the registry. Follow these steps:

  1. Start Registry Editor (Regedt32).
  2. Locate the following key:
    HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon\DontDisplayLastUserName
    					
  3. Change the value to zero (0).
  4. Quit Registry Editor.

Modification Type:MinorLast Reviewed:7/15/2004
Keywords:kbprb KB248645