Direct Mailing Fails to Send to Some ISPs (248607)



The information in this article applies to:

  • Microsoft Site Server 3.0

This article was previously published under Q248607

SYMPTOMS

When you use Direct Mailer to send Simple Mail Transfer Protocol (SMTP) e-mail, some e-mail recipients fail to receive the message.

CAUSE

Some ISPs reject the message if the "from" line in the rfc822 envelope contains an invalid domain address.

RESOLUTION

To resolve this problem, use the Masquerade Domain field in SMTP to modify the 822 envelope:
  1. Launch the Microsoft Management Console for SMTP.
  2. Right click the SMTP server and select Properties.
  3. Select the Delivery tab.
  4. Change the Masquerade Domain field to reflect a valid fully qualified domain name (FQDN).
The Masquerade Domain replaces the local domain name listing in "from" lines in the message header or "MailFrom" lines in the protocol.

Modification Type:MajorLast Reviewed:2/16/2000
Keywords:kbprb KB248607